S aktualizáciou na WooCommerce 3.0 radšej počkajte

Tešíme sa, že vyšiel nový WooCommerce 3.0. Prináša viacero zmien a vylepšení, no s aktualizáciou odporúčam radšej pát týždňov počkať.

WooCommerce je čo sa týka kódu obrovský plugin. V podstate skoro tak veľký ako samotný WordPress. Pre WooCommerce existujú tisícky rozšírení od stovák rôznych programátorov, ktorí častokrát svoje pluginy vyvíjajú vo voľnom čase. Vždy keď vyjde nová verzie je dobré nechať vývojárom nejaký čas, nech vychýtajú chyby a upravia ich pluginy tak, aby boli kompatibilné s novou verziou.

Takisto ešte nemáme dokončený preklad pre WooCommerce 3.0, takže ak by si aj aktualizoval, nebudeš mať WooCommerce k dispozícii v slovenskom jazyku. Prekladať môže naozaj skoro každý, kto vie akotak anglicky a slovensky. Chýbajúce frázy pre preklad nájdeš na translate.wordpress.org.

Ďalšie dôvody prečo sa neponáhľať s aktualizáciou pekne zhrnul Musilda v jeho článku.

Do kedy počkať?

Ja by som počkal aspoň mesiac na opravu väčšinu chýb, ktoré sa dovtedy objavia. Predpokladám, že verzia 3.0.2 alebo 3.0.3 bude už celkom bezpečná na aktualizáciu. A verím, že slovenský preklad dokončíme najneskôr počas Contributor v rámci WordCamp Bratislava, ktorý bude 29. – 30. apríla.

The following two tabs change content below.

Peter Nemčok

umožňovateľ at Webikon
Zakladateľ komunitného portálu WordPress Slovensko a líder v slobodnej firme Webikon. S WordPress pracuje od roku 2007 a od roku 2008 je hlavným validátorom slovenského prekladu WordPress. Organizuje WordPress meetupy, WordCamp Slovensko a WordCamp Europe.

6 komentárov


    1. Vďaka za pomoc s prekladom. Na Contributor Day počas WordCamp Bratislava preklad poschvaľujeme, takže od mája bude určite opäť dostupný na stiahnutie.

      Odpovedať

      1. Pekný deň prajem
        Chcem sa iba spýtať, či už viete približný dátum, kedy bude preklad dostupný.
        Ďakujem

        Odpovedať

  1. Bezpečnostné aktualizácie odporúčam vždy nasadiť čo najskôr. Tieto hlavné verzie, napríklad WordPress 4.8 alebo WooCommerce 3.0, nikdy neobsahujú bezpečnostné aktualizácie. Tie sú vždy vydávané len ako menšie verzie, napríklad WordPress 4.7.1.

    Odpovedať

  2. heh, veru pravda, neskoro.. par veci rozhasenych, teraz si pockam si kym dobehnu pluginy

    ale .. ak sa zverejni chyba ktoru plugin opravuje nemyslim si ze je „bezpecne cakat“.. z hladiska funkcnosti ale urcite vhodne 🙂 .. v tomto pripade nemam potuchy ci tam nieco take kriticke je ..

    Odpovedať

Pridaj komentár